Ticket #94 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

Potential incorrect ordering of create_tables with inherited models

Reported by: andrew Owned by: andrew
Priority: minor Milestone: 0.6
Component: migrations Version: 0.6-pre
Keywords: Cc:

Description

Related to the recent proper inheritance fix [160], there's a need to insert the tables in the right order (i.e. descending the tree of inheritance), else Postgres complains.

When it comes to detecting model ordering, we have the technology - just scan the models, and create a relation between app.model keys.

Change History

comment:1 Changed 5 years ago by andrew

  • Status changed from new to assigned

comment:2 Changed 5 years ago by andrew

  • Milestone changed from 0.5 to 0.6

Haven't seen this occur so much recently, so pushing back to 0.6 for a proper fix.

comment:3 Changed 5 years ago by andrew

  • Status changed from assigned to closed
  • Resolution set to duplicate

Marking as duplicate of #150, since that's ordering too.

Note: See TracTickets for help on using tickets.