Modify

Ticket #711 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Problems with Oracle, field creation, and NULL

Reported by: Alan.Dyke@… Owned by: andrew
Priority: minor Milestone: 1.0
Component: databaseapi Version: 0.7.3
Keywords: Cc:

Description

SQL for field creation containing NOT NULL DEFAULT XX is correctly switched to DEFAULT XX NOT NULL for oracle, but equivalent clause of NULL DEFAULT XX is not switched.

Additionally, NOT NULL PRIMARY KEY DEFAULT XX is passed through to oracle, and then fails.

Attachments

south.diff (961 bytes) - added by andrew 3 years ago.

Change History

Changed 3 years ago by andrew

comment:1 Changed 3 years ago by andrew

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #412

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.