Modify

Ticket #405 (closed enhancement: duplicate)

Opened 4 years ago

Last modified 4 years ago

Permissions set through class Meta are not picked up

Reported by: malcolm.box@… Owned by: andrew
Priority: minor Milestone:
Component: migrations Version: 0.7
Keywords: Cc:

Description

If you use the model Meta class to create custom permissions e.g.:

class myModel(models.Model)

class Meta:

permissions = (

("login_console", "Can login to console"),

)

Then this change is not detected by South, and the corresponding Permission object is not created in the database.

The auto-detection should pick this up and DTRT

Attachments

Change History

comment:1 Changed 4 years ago by andrew

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #211.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.