Modify

Ticket #383 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

altering sqlite columns creates invalid sql

Reported by: alex@… Owned by: andrew
Priority: major Milestone: 0.7
Component: commands Version: 0.7-pre
Keywords: Cc:

Description

the column name for altered columns was duplicated. for example:
{{{{
south execute "CREATE TABLE "_south_new_market_entry" ("used" bool, "description" text, "title" varchar(200), "image" image, "changed" datetime, "plz" integer, "id" integer PRIMARY KEY, "reminder_sent" bool, "cost" "cost" decimal NOT NULL, "location" varchar(200), "published" datetime, "customer_id" integer, "slug" varchar(50), "vat" bool, "category_id" integer)" with params "[]"
}}}}

see colum "cost". the problem is in _remake_table: altered contains the name, type doesn't. proposed patch is attached.

Attachments

south-sqlite-alter-column.patch (1.1 KB) - added by alex@… 4 years ago.
south-sqlite-alter-column-2.patch (1.2 KB) - added by Alexander Clausen <alex@…> 4 years ago.
sorry, first patch was broken
south-sqlite-alter-column-3.patch (1.3 KB) - added by Alexander Clausen <alex@…> 4 years ago.
renames where broken by the patch, fix it

Change History

Changed 4 years ago by alex@…

Changed 4 years ago by Alexander Clausen <alex@…>

sorry, first patch was broken

Changed 4 years ago by Alexander Clausen <alex@…>

renames where broken by the patch, fix it

comment:1 Changed 4 years ago by andrew

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone set to 0.7

Fixed in [eb5a5f86d57a].

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.