Modify

Ticket #348 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

South breaks permission creation

Reported by: a4blank@… Owned by: andrew
Priority: major Milestone: 0.7
Component: commands Version: 0.6.2
Keywords: permission Cc:

Description

For non-migrated apps django automatically adds new default (add, change, delete) permissions on syncdb.
For migrated apps syncdb does not do that and nothing else does, so you don't get permissions for new models installed.

Workaround is to run syncdb --all, however it is just a workaround

Attachments

Change History

comment:1 Changed 4 years ago by andrew

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone set to 0.7

Marking this as a duplicate of #211, which it is, mostly (that ticket does mention that South also breaks permissions full stop). I'll hopefully be able to have a look at it soon.

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.