Ticket #263 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

[mysql] Incorrect SQL issued for TimeField with default value

Reported by: tomasz.zielinski@… Owned by: andrew
Priority: major Milestone:
Component: commands Version: 0.6
Keywords: Cc:

Description

In models.py:

time_field = models.TimeField?(default=datetime.time.min)

  • for such field South issues SQL instruction that contains dafault value of 00:00:00, whereas it should be '00:00:00' - at least that's what MySQL Query Browser accepts.

Change History

comment:1 Changed 5 years ago by andrew

  • Status changed from new to closed
  • Resolution set to duplicate

As far as I can see, this is a duplicate of #254. Times are correctly quoted for me.

Note: See TracTickets for help on using tickets.