Modify

Ticket #258 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

post_syncdb is not sent to handlers registered in migrated apps

Reported by: miracle2k Owned by: andrew
Priority: minor Milestone:
Component: commands Version: 0.6
Keywords: Cc:

Description

In my main application, using south migrations, I need to setup a handler for the post_syncdb signal; doing so in the management module, as the Django docs suggest to do, will cause the signal handler not to be picked up, because before South calls the original syncdb, it removes the app from the list.

Registering the handler in models.py works, since that is executed by south itself during loading; still, it took me a while to track this down.

Not sure what can be done about it; maybe south could send the signal itself?

Attachments

Change History

comment:1 Changed 5 years ago by andrew

  • Status changed from new to closed
  • Resolution set to duplicate

A duplicate of the (badly-named) #171.

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.