Ticket #223 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Unit tests fail if other migrations are run

Reported by: simon@… Owned by: andrew
Priority: critical Milestone: 0.6
Component: migrations Version: 0.6-pre
Keywords: tests Cc: juan@…

Description

Reproduction steps:

  1. Add SOUTH_TESTS_MIGRATE = True to settings.py in your program, that has migrations in it.
  2. Run manage.py test

Bug:
The south tests fail, because they check that the MigrationHistory? table is empty.

The included patch remedies this.

Attachments

unittest-clear-migrations.patch (721 bytes) - added by simon@… 5 years ago.
unittest-clear-migrations.2.patch (679 bytes) - added by simon@… 5 years ago.
Better patch

Change History

Changed 5 years ago by simon@…

Changed 5 years ago by simon@…

Better patch

comment:1 Changed 5 years ago by andrew

  • Status changed from new to closed
  • Resolution set to fixed

Applied in [148ad6c7f1b5].

comment:2 Changed 5 years ago by andrew

  • Milestone set to 0.6

comment:3 Changed 5 years ago by simon@…

It looks like this changeset hasn't been pushed yet...

Note: See TracTickets for help on using tickets.