Modify

Ticket #1161 (closed defect: duplicate)

Opened 20 months ago

Last modified 14 months ago

syncdb --all does not respect multidb routers

Reported by: ash.christopher@… Owned by: andrew
Priority: major Milestone:
Component: commands Version: unknown
Keywords: syncdb multidb Cc:

Description

When running syncdb with the --all flag, it seems to ignore the allow_syncdb() method of the routers.

Database tables that I expected to see only exist on the secondary databases are showing up on the default database.

Attachments

Change History

comment:1 Changed 20 months ago by andrew

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #370.

comment:2 Changed 14 months ago by vhermecz@…

Wohohoooo. Holy moat!

For the record, to help others, i'd state that:

  1. the --database switch can be used to identify a db different from django default for the operation
  2. south as is today, is lower level than multidb. It does always work on one database. Btw which defaults to default as it is setup in django
View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.