Modify

Ticket #1139 (closed defect: duplicate)

Opened 22 months ago

Last modified 22 months ago

pip install django-south reports 0.7.5 but missing schemamigration --update functionality

Reported by: anonymous Owned by: andrew
Priority: major Milestone:
Component: commands Version: 0.7.5
Keywords: schemamigration update Cc:

Description

According to the docs tehre should be an update option to schemamigration.
http://south.readthedocs.org/en/latest/commands.html#id1

However, installing via pip at least as far back 0.7.3 this functionality is oddly absent at the source.

class Command(DataCommand):
    option_list = DataCommand.option_list + (
        make_option('--add-model', action='append', dest='added_model_list', type='string',
            help='Generate a Create Table migration for the specified model.  Add multiple models to this migration with subsequent --model parameters.'),
        make_option('--add-field', action='append', dest='added_field_list', type='string',
            help='Generate an Add Column migration for the specified modelname.fieldname - you can use this multiple times to add more than one column.'),
        make_option('--add-index', action='append', dest='added_index_list', type='string',
            help='Generate an Add Index migration for the specified modelname.fieldname - you can use this multiple times to add more than one column.'),
        make_option('--initial', action='store_true', dest='initial', default=False,
            help='Generate the initial schema for the app.'),
        make_option('--auto', action='store_true', dest='auto', default=False,
            help='Attempt to automatically detect differences from the last migration.'),
        make_option('--empty', action='store_true', dest='empty', default=False,
            help='Make a blank migration.'),
    )
    help = "Creates a new template schema migration for the given app"
    usage_str = "Usage: ./manage.py schemamigration appname migrationname [--empty] [--initial] [--auto] [--add-model ModelName] [--add-field ModelName.field_name] [--stdout]"
    
    def handle(self, app=None, name="", added_model_list=None, added_field_list=None, freeze_list=None, initial=False, auto=False, stdout=False, added_index_list=None, verbosity=1, empty=False, **options):

Attachments

Change History

comment:1 Changed 22 months ago by andrew

  • Status changed from new to closed
  • Resolution set to duplicate

It's not in a released version yet (duplicate of #1136).

comment:2 Changed 22 months ago by anonymous

Thanks!

View

Add a comment

Modify Ticket

Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.