Modify

Ticket #1126 (closed defect: worksforme)

Opened 2 years ago

Last modified 2 years ago

TypeError: handle() got multiple values for keyword argument 'added_model_list'

Reported by: waverider6 Owned by: andrew
Priority: minor Milestone:
Component: migrations Version: 0.7.5
Keywords: Cc:

Description

Hi,

When I run:

python manage.py schemamigration api –auto session_model_added

I get:

Traceback (most recent call last):

File "manage.py", line 10, in <module>

execute_from_command_line(sys.argv)

File "/Library/Frameworks/Python?.framework/Versions/2.7/lib/python2.7/site-packages/django/core/management/init.py", line 443, in execute_from_command_line

utility.execute()

File "/Library/Frameworks/Python?.framework/Versions/2.7/lib/python2.7/site-packages/django/core/management/init.py", line 382, in execute

self.fetch_command(subcommand).run_from_argv(self.argv)

File "/Library/Frameworks/Python?.framework/Versions/2.7/lib/python2.7/site-packages/django/core/management/base.py", line 196, in run_from_argv

self.execute(*args, options.dict)

File "/Library/Frameworks/Python?.framework/Versions/2.7/lib/python2.7/site-packages/django/core/management/base.py", line 232, in execute

output = self.handle(*args, options)

TypeError?: handle() got multiple values for keyword argument 'added_model_list'

Can't figure out what the problem is. Your help would be highly appreciated!

Attachments

Change History

comment:1 Changed 2 years ago by andrew

  • Status changed from new to closed
  • Resolution set to worksforme

You've got a long dash (–) rather than two hyphens (--) - fix that and it should work fine.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.