Ticket #1077 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

Migration for an empty model

Reported by: i@… Owned by: andrew
Priority: major Milestone:
Component: commands Version: 0.7.4
Keywords: Cc:

Description

I tried to create an initial migration for an empty model, got

# -*- coding: utf-8 -*-
import datetime
from south.db import db
from south.v2 import SchemaMigration
from django.db import models


class Migration(SchemaMigration):

    def forwards(self, orm):
pass
    def backwards(self, orm):
pass
    models = {
        
    }

    complete_apps = ['core']

with raising IndentationError: expected an indented block.

Attachments

empty_model_indenttation.patch (779 bytes) - added by i@… 2 years ago.
Fixing patch

Change History

Changed 2 years ago by i@…

Fixing patch

comment:1 Changed 2 years ago by andrew

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1064.

Note: See TracTickets for help on using tickets.